Fix Equalizer APO Not Working in Windows 10

The Problem

Equalizer APO is not taking any effect in Windows 10.

The Solution

  1. Open the Configurator program by searching for it in Start.
  2. Select your device and check “Troubleshooting options“.
  3. Choose “Install as SFX/EFX (experimental)“.
  4. Restart Windows.

In recent versions of Windows 10, UWP apps like “Movies & TV” may not get processed by Equalizer APO even with this fix.

Subscribe
Notify of
guest
34 Comments
Oldest
Newest
Inline Feedbacks
View all comments
Kamer Veselji
Kamer Veselji
1 year ago

This did not work for me.

Duy
Duy
1 year ago

Fak! That works!

However, I don’t understand why it didn’t take any effect since the first time installing it worked. I messed up with Razor Surround software, installed and finally removed it then Equalizer APO no longer work.

Paul
Paul
1 year ago

This did not work for me either. When I first installed APO on Windows 10, it worked great but it suddenly stopped working for no apparent reason. Exactly the same problem on a different desktop with Windows 10 Pro (1803) 64-bit.

AntiSpamProtection
AntiSpamProtection
1 year ago

This did not fix anything, instead, it made no audio come at all

Adam
Adam
1 year ago

Thanks. This worked!

Jamie Taylor
Jamie Taylor
1 year ago

This fixed it for me! Thanks so much!

Guest
Guest
1 year ago

This worked for me!!! Thank you so, so much. This was really starting to get frustrating. My headset lacks a little punch in the bass department, so I was upset that the software wasn’t working initially. Thanks again!

jason
jason
11 months ago

This worked for me on windows 10 thanks

Bob
Bob
11 months ago

Thank you very much, It worked for me 🙂

Jason A.
Jason A.
11 months ago

Thank you so much! It worked for me on HP 14 Laptop! 🙂

Honza Pačuta
Honza Pačuta
11 months ago

Thanks, that did it for me.

Joseph Maggio
Joseph Maggio
10 months ago

FIX EQUALIZER APO NOT WORKING IN WINDOWS 10

Ray
Ray
10 months ago

Wow, was NOT expecting this to work, thankyou!

Thomas
Thomas
9 months ago

Worked as intended, thank you so much!!

Kululul Uluolulu
Kululul Uluolulu
8 months ago

Worked, thank you sir !

Pato
Pato
8 months ago

Amazing, just the fix I needed. My EQ is now registering changes and I can hear them.

Jeremy from Canada
Jeremy from Canada
8 months ago

This worked for me (used peace) 01-12-2019 🙂

Oskar
Oskar
7 months ago

Thank you so much, this worked well. (Used Peace)

Chris
Chris
6 months ago

This just isn’t working. Have tried the fix mentioned above. Unbelieveable that Windows has gone backwards since Win7, and no-one seems to be complaining. No drag and drop in MS’s pointless “Groove” app, and now no possible way to get basic EQ system-wide without paying for an app (Realtek also… Read more »

Mark
Mark
5 months ago

Thanks so much for this whoever posted it! I had copy channel working more by look with the Microsoft HD audio driver, but when I switched to Realtek audio drivers (damn I hate Realtek audio drivers), it never worked, no matter what I tried. And it seems since Windows 10… Read more »

Michal K
Michal K
3 months ago

It helped me aswell, I’m so happy, such relief, thank you!

doufun11
doufun11
3 months ago

Thanks, it worked!! Finally can achieve the full potential of my HS50 pro’s.

Valen
Valen
3 months ago

This is indeed working for me with games on windows 10.

Oficial
Oficial
3 months ago

I have APO on a XPS DELL tower win windows 10 an it works well. Now I had installed APO on an Alienware DELL tower with W10 1909 version, but it dose not work. I have tried install again and again but I can not select the option Choose “Install… Read more »

Piotr
Piotr
1 month ago

Thank you so much! I tried reinstalling, cleaning the registry, turning on and off some audio enhancements but finally your solution did the trick! 🙂

Martin
Martin
23 days ago

THANKS! that works!

Dennis
Dennis
23 days ago

the problem for me is, i can’t open the configurator.